// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\>(.*?)\<").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>
<retorno><estoques><estoque><id>15872782438</id><codigo>teste-branco</codigo><nome>teste cor:branco</nome><estoqueatual>15</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>15</saldo><saldovirtual>15</saldovirtual></deposito></depositos></estoque><estoque><id>15872782439</id><codigo>teste-azul</codigo><nome>teste cor:azul</nome><estoqueatual>129</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>129</saldo><saldovirtual>129</saldovirtual></deposito></depositos></estoque><estoque><id>15872782441</id><codigo>teste-preto</codigo><nome>teste cor:preto</nome><estoqueatual>35</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>35</saldo><saldovirtual>35</saldovirtual></deposito></depositos></estoque><estoque><id>15872782434</id><codigo>teste</codigo><nome>teste</nome><estoqueatual>0</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>0</saldo><saldovirtual>0</saldovirtual></deposito></depositos></estoque></estoques></retorno>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}