#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\>(.*?)\<"
Local $sString = "<?xml version="1.0" encoding="utf-8"?>" & @CRLF & _
"<retorno><estoques><estoque><id>15872782438</id><codigo>teste-branco</codigo><nome>teste cor:branco</nome><estoqueatual>15</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>15</saldo><saldovirtual>15</saldovirtual></deposito></depositos></estoque><estoque><id>15872782439</id><codigo>teste-azul</codigo><nome>teste cor:azul</nome><estoqueatual>129</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>129</saldo><saldovirtual>129</saldovirtual></deposito></depositos></estoque><estoque><id>15872782441</id><codigo>teste-preto</codigo><nome>teste cor:preto</nome><estoqueatual>35</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>35</saldo><saldovirtual>35</saldovirtual></deposito></depositos></estoque><estoque><id>15872782434</id><codigo>teste</codigo><nome>teste</nome><estoqueatual>0</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>0</saldo><saldovirtual>0</saldovirtual></deposito></depositos></estoque></estoques></retorno>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")