import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(\d+)\s+(\w{2})\s*(\w{2,5})\s+(\w{5})(\s+|\s+.\s+)(\w{3})(\w{3})(\s+|(\s|\*)\w{3}\s+)(\w{4,5})\s+(\w{4,5})\s+(\w{5})?(\s|.)*(?:\n|$){1}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 UA 990J 28OCT SFOCDG 340P 1015A 29OCT
fefeff
2 AF1830J 31OCT CDGMXP 900A 1025A 31OCT
OPERATED BY AIR CANADA
YYZ CHECK-IN WITH AIR CANADA
3 LH 259J 03NOV T MXPFRA 740A 900A 03NOV
OPERATED BY LUFTHANSA
MAD CHECK-IN WITH LUFTHANSA
4 DL2252Z 01OCT T SATDTW*SS1 1246P 454P
5 DL 98Z 01OCT T DTWCDG*SS1 608P 805A 02OCT W /DCDL /E
6 DL8322Z 02OCT W CDGBOD*SS1 935A 1050A /DCDL /E
OPERATED BY AIR FRANCE
7 DL9365Z 09OCT W BODAMS*SS1 1150A 140P /DCDL /E
OPERATED BY KLM ROYAL DUTCH AIRLINES
8 DL8178Z 09OCT W AMSSLC*SS1 500P 655P /DCDL /E
OPERATED BY KLM ROYAL DUTCH AIRLINES
10 LH 454J 03NOV FRASFO 1005A 205P 03NOV
11 LH 454J 03NOV SFOKIV 205P 235P 03NOV
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)