#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)(\d+)\s+(\w{2})\s*(\w{2,5})\s+(\w{5})(\s+|\s+.\s+)(\w{3})(\w{3})(\s+|(\s|\*)\w{3}\s+)(\w{4,5})\s+(\w{4,5})\s+(\w{5})?(\s|.)*(?:\n|$){1}"
Local $sString = " 1 UA 990J 28OCT SFOCDG 340P 1015A 29OCT" & @CRLF & _
"fefeff" & @CRLF & _
"2 AF1830J 31OCT CDGMXP 900A 1025A 31OCT " & @CRLF & _
"OPERATED BY AIR CANADA" & @CRLF & _
"YYZ CHECK-IN WITH AIR CANADA" & @CRLF & _
"3 LH 259J 03NOV T MXPFRA 740A 900A 03NOV" & @CRLF & _
"OPERATED BY LUFTHANSA" & @CRLF & _
"MAD CHECK-IN WITH LUFTHANSA" & @CRLF & _
"" & @CRLF & _
"4 DL2252Z 01OCT T SATDTW*SS1 1246P 454P" & @CRLF & _
"5 DL 98Z 01OCT T DTWCDG*SS1 608P 805A 02OCT W /DCDL /E" & @CRLF & _
"6 DL8322Z 02OCT W CDGBOD*SS1 935A 1050A /DCDL /E" & @CRLF & _
"OPERATED BY AIR FRANCE" & @CRLF & _
"" & @CRLF & _
"7 DL9365Z 09OCT W BODAMS*SS1 1150A 140P /DCDL /E" & @CRLF & _
"" & @CRLF & _
"OPERATED BY KLM ROYAL DUTCH AIRLINES" & @CRLF & _
"8 DL8178Z 09OCT W AMSSLC*SS1 500P 655P /DCDL /E" & @CRLF & _
"OPERATED BY KLM ROYAL DUTCH AIRLINES" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"10 LH 454J 03NOV FRASFO 1005A 205P 03NOV" & @CRLF & _
"11 LH 454J 03NOV SFOKIV 205P 235P 03NOV"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")