$re = '/^#?([0-9a-f]{6}|[0-9a-f]{3})$/i';
$str = '#ffffff';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);