const regex = /^#?([0-9a-f]{6}|[0-9a-f]{3})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#?([0-9a-f]{6}|[0-9a-f]{3})$', 'i')
const str = `#ffffff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}