// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z0-9]=)|(\n\s*\{)|(\(\s)|(\s\))|(\s,)|(\n\s*\{)|(\t)|(\)\{)|(.{81,})|([a-zA-Z0-9][&|\+\-\*\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])").unwrap();
let string = "Any \"matches\" here indicate a possible style error.
Please note that this is not 100% perfect (although we tried our best!)
This may not catch everything, and may incorrectly catch others.
If you believe there is an incorrect match, let us know
on the form when you submit your document.
Please ignore any matches within your comments or string literals.
(i.e. you can break \"coding style\" in a comment)
Thank you!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}