const regex = /([a-zA-Z0-9]=)|(\n\s*\{)|(\(\s)|(\s\))|(\s,)|(\n\s*\{)|(\t)|(\)\{)|(.{81,})|([a-zA-Z0-9][&|\+\-\*\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9]=)|(\\n\\s*\\{)|(\\(\\s)|(\\s\\))|(\\s,)|(\\n\\s*\\{)|(\\t)|(\\)\\{)|(.{81,})|([a-zA-Z0-9][&|\\+\\-\\*\\\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])', 'g')
const str = `Any "matches" here indicate a possible style error.
Please note that this is not 100% perfect (although we tried our best!)
This may not catch everything, and may incorrectly catch others.
If you believe there is an incorrect match, let us know
on the form when you submit your document.
Please ignore any matches within your comments or string literals.
(i.e. you can break "coding style" in a comment)
Thank you!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}