re = /(?<!\s)(\s\S+?)(?:\r\n?|\n|\z)/
str = 'Some line of text ending witha line terminator
Always find the lsat word with or without a line terminator not including a Space
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end