const regex = /(?<!\s)(\s\S+?)(?:\r\n?|\n|\z)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\s)(\\s\\S+?)(?:\\r\\n?|\\n|\\z)', 'g')
const str = `Some line of text ending witha line terminator
Always find the lsat word with or without a line terminator not including a Space
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}