import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(< *br)[ \\/]*>";
final String string = "/* Linebreaks */\n"
+ "<br>\n"
+ "<br />\n"
+ "<br/>\n\n"
+ "/* Terrible linebreaks, but technically possible */\n"
+ "< br />\n"
+ "< br>\n"
+ "< br/>\n"
+ "< br>\n"
+ "<br />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}