using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(< *br)[ \/]*>";
string input = @"/* Linebreaks */
<br>
<br />
<br/>
/* Terrible linebreaks, but technically possible */
< br />
< br>
< br/>
< br>
<br />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}