use strict;
my $str = 'rnbqkbnr/pp1ppppp/8/2p5/4P3/5N2/PPPP1PPP/RNBQKB1R b KQkq - 1 2';
my $regex = qr/^
(?# Piece Placement Section)(?<PiecePlacement>((?<RankItem>[pnbrqkPNBRQK1-8]{1,8})\/?){8})
(?# Section Separator)\s+
(?# Side To Move Section) (?<SideToMove>b|w)
(?# Section Separator)\s+
(?# Castling Ability) (?<Castling>-|K?Q?k?q)
(?# Section Separator)\s+
(?# En passant) (?<EnPassant>-|[a-h][3-6])
(?# Section Separator)\s+
(?# Half Move Clock) (?<HalfMoveClock>\d+)
(?# Section Separator)\s+
(?# Full Move Number) (?<FullMoveNumber>\d+)
\s*
$/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}