re = /^\d+.\d+,/m
str = '20.000,20.000,4
20.000,20.000,4
20.000,20.000,4
20.000,20.000,4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end