import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_([0-9]*)";
final String string = "https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_1032027fd\n\n"
+ "https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_32027fd\n\n"
+ "https://tn.com.ar/politica/la-iglesia-convoco-para-el-8-de-marzo-una-misa-contra-la-despenalizacion-del-aborto_11032027fd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}