const regex = new RegExp('^\\$cdt\\[([a-zA-Z_][a-zA-Z0-9_]{3,100}),([a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}),([a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}),?([a-zA-Z0-9_\\- ]{1,100}=[a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}(?:;[a-zA-Z0-9_\\- ]{1,100}=[a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500})*)?]$', 'gm')
const str = `\$cdt[cdt1,\$[col1]-4==1,\$[col2]+\$[col3],var1=1;var2=2+1;var3=6==6]
\$cdt[cdt1,\$[col1]-4==1,\$[col2]+\$[col3]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}