import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$cdt\\[([a-zA-Z_][a-zA-Z0-9_]{3,100}),([a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}),([a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}),?([a-zA-Z0-9_\\- ]{1,100}=[a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500}(?:;[a-zA-Z0-9_\\- ]{1,100}=[a-zA-Z0-9_+\\-*/%&|^!=<>\\[\\]$ ]{1,500})*)?]$";
final String string = "$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3],var1=1;var2=2+1;var3=6==6]\n"
+ "$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}