const regex = new RegExp('(?:[/-]+(?<key>\\S+?))|(?:""[/-]+(?<key>.+?)"")|(?:\\'[/-]+(?<key>.+?)\\')|(?:""(?<value>.+?)"")|(?:\\'(?<value>.+?)\\')|(?<value>\\S+)', 'gm')
const str = `command.exe "/c" '/f' --i file1.txt 'new 2.txt' -o "new file.txt"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}