using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[/-]+(?<key>\S+?))|(?:""[/-]+(?<key>.+?)"")|(?:'[/-]+(?<key>.+?)')|(?:""(?<value>.+?)"")|(?:'(?<value>.+?)')|(?<value>\S+)";
string input = @"command.exe ""/c"" '/f' --i file1.txt 'new 2.txt' -o ""new file.txt""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}