$re = '/(?:(?:ию[нл]|январ|(?:апре|февра)л|(?:сент|окт|но|дек)[яа]бр)ь|(?:ма|авгу)(?:[рс]?т|й))/';
$str = '18.08.2022 - Статьи на внешку - 2 - Яценко - август - mramor-granit.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);