import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:ию[нл]|январ|(?:апре|февра)л|(?:сент|окт|но|дек)[яа]бр)ь|(?:ма|авгу)(?:[рс]?т|й))";
final String string = "18.08.2022 - Статьи на внешку - 2 - Яценко - август - mramor-granit.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}