$re = '/^<img((?!alt=".*")(\n|.))*(>|\/>)$/m';
$str = '<img >
<img src="jasfslkj" alt="kaas">
<img koffie="zwart"
/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);