using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<img((?!alt="".*"")(\n|.))*(>|\/>)$";
string input = @"<img >
<img src=""jasfslkj"" alt=""kaas"">
<img koffie=""zwart""
/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}