// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"chip="(?<value>[^"]+)|chip_name="(?<text>[^"]+)"#).unwrap();
let string = "node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_0\",chip_name=\"enp216s0f0np0\"} 1
node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_1\",chip_name=\"enp216s0f0np1\"} 1
node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_2\",chip_name=\"enp216s0f0np2\"} 1
node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_3\",chip_name=\"enp216s0f0np3\"} 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}