import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "chip=\"(?<value>[^\"]+)|chip_name=\"(?<text>[^\"]+)";
final String string = "node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_0\",chip_name=\"enp216s0f0np0\"} 1\n"
+ "node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_1\",chip_name=\"enp216s0f0np1\"} 1\n"
+ "node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_2\",chip_name=\"enp216s0f0np2\"} 1\n"
+ "node_hwmon_chip_names{chip=\"0000:d7:00_0_0000:d8:00_3\",chip_name=\"enp216s0f0np3\"} 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}