import Foundation
let pattern = #"<(ul|ol)>\s*<li>{([ .\w-]+)} *(.*?)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<ul>
<li>{ .class .asdf}some item</li>
<li>another</li>
</ul>
<ul>
<li>{.class} some item</li>
<li>another</li>
</ul>
<p>{.test}Content of the paragrap
</p>
<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)