#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<(ul|ol)>\s*<li>{([ .\w-]+)} *(.*?)<\/\1>"
Local $sString = "" & @CRLF & _
"<ul>" & @CRLF & _
" <li>{ .class .asdf}some item</li>" & @CRLF & _
" <li>another</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>{.class} some item</li>" & @CRLF & _
" <li>another</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p>{.test}Content of the paragrap" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")