$re = '/(\b[^()]+\b)\s*\(\s*(\b[^()]+\b)\s*\)/m';
$str = ' textA ( text B ) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);