package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b[^()]+\b)\s*\(\s*(\b[^()]+\b)\s*\)`)
var str = ` textA ( text B ) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}