$re = '/([\d]+)(?:立减|-|减)([\d]+)/m';
$str = '满减:爱乐维 满199-30,满29立减5 ,满49减10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);