const regex = /([\d]+)(?:立减|-|减)([\d]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d]+)(?:立减|-|减)([\\d]+)', 'gm')
const str = `满减:爱乐维 满199-30,满29立减5 ,满49减10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}