// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) .*$").unwrap();
let string = "9/9/43 12:00 AM/PM
9/17/88 12:00 AM/PM
11/21/48 12:00 AM/PM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}