import Foundation
let pattern = #"<svg[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
<!-- Generator: Adobe Illustrator 23.0.2, SVG Export Plug-In -->
<svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="53.5px"
height="42.8px" viewBox="0 0 53.5 42.8" style="enable-background:new 0 0 53.5 42.8;" xml:space="preserve">
<style type="text/css">
.st0{fill:#C49039;}
</style>
<defs>
</defs>
<path class="st0" d="M53.5,21.4C53.5,8.6,44.2,0,28.4,0H0v42.8h28.4C44.2,42.8,53.5,33.9,53.5,21.4z"/>
</svg>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)