# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<svg[^>]+>"
test_str = ("<!-- Generator: Adobe Illustrator 23.0.2, SVG Export Plug-In -->\n"
"<svg version=\"1.1\" xmlns=\"http://www.w3.org/2000/svg\" xmlns:xlink=\"http://www.w3.org/1999/xlink\" x=\"0px\" y=\"0px\" width=\"53.5px\"\n"
" height=\"42.8px\" viewBox=\"0 0 53.5 42.8\" style=\"enable-background:new 0 0 53.5 42.8;\" xml:space=\"preserve\">\n"
"<style type=\"text/css\">\n"
" .st0{fill:#C49039;}\n"
"</style>\n"
"<defs>\n"
"</defs>\n"
"<path class=\"st0\" d=\"M53.5,21.4C53.5,8.6,44.2,0,28.4,0H0v42.8h28.4C44.2,42.8,53.5,33.9,53.5,21.4z\"/>\n"
"</svg>\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.