$re = '/^\g<body>$(?<body>(?:[^\()]|\g<parens>)*){0}(?<parens>\(\g<body>\)){0}/';
$str = '() 90\\()(())';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);