package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\g<body>$(?<body>(?:[^\()]|\g<parens>)*){0}(?<parens>\(\g<body>\)){0}`)
var str = `() 90\()(())`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}