$re = '/(https?:\/\/)?(w{3}\.)?(\w+\.\w{2,3}\.\w{2}?)?(\w+-)?(:?%?\w{2,}\/?\.\w{2,3})?(\/\w+)?(\/[\d\w].+\s$)?(:\d+)?/i';
$str = '
https://www.google.co.in/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=trie+data+structure+tutorial+%7C+explanation
http://vnc.example.com:5800
gskinner.com/products/spl
gskinner.com
adobe.com/go/flex
google.in
http://boswebsvr009:8090/confluence/display/DEV/Training+for+2015+batch+junior+engineers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);