package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?:\/\/)?(w{3}\.)?(\w+\.\w{2,3}\.\w{2}?)?(\w+-)?(:?%?\w{2,}\/?\.\w{2,3})?(\/\w+)?(\/[\d\w].+\s$)?(:\d+)?`)
var str = `
https://www.google.co.in/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=trie+data+structure+tutorial+%7C+explanation
http://vnc.example.com:5800
gskinner.com/products/spl
gskinner.com
adobe.com/go/flex
google.in
http://boswebsvr009:8090/confluence/display/DEV/Training+for+2015+batch+junior+engineers`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}