re = /\[(.+?)\]\((https?:\/\/|ftp:\/\/|mailto:[^\)]+)\)/i
str = '[Another link to Google](http://www.google.com), [a secure link to Google](https://www.google.com),
[Bad link to Google](www.google.com)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end