$re = '/\[(.+?)\]\((https?:\/\/|ftp:\/\/|mailto:[^\)]+)\)/i';
$str = '[Another link to Google](http://www.google.com), [a secure link to Google](https://www.google.com),
[Bad link to Google](www.google.com)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);