use strict;
my $str = '1F2EB4CE-5A7E-419F-9346-25885EB9D575';
my $regex = qr/[0-9|A-Z]{8}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{12}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}