#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9|A-Z]{8}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{12}"
Local $sString = "1F2EB4CE-5A7E-419F-9346-25885EB9D575"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")