import Foundation
let pattern = #".* \w+ (?=\()|(\(\d{4}_\d{2}_\d{2}\s\d{2}_\d{2}_\d{2}\s\w{3}\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Acacia tree 2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg
Acacia tree 2 (2015_12_03 14_18_17 UTC).jpg
JOURNEY TO ARABIA (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png
Acacia Tree 4 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)