using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".* \w+ (?=\()|(\(\d{4}_\d{2}_\d{2}\s\d{2}_\d{2}_\d{2}\s\w{3}\))";
string input = @"
Acacia tree 2 (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).jpg
Acacia tree 2 (2015_12_03 14_18_17 UTC).jpg
JOURNEY TO ARABIA (2014_10_06 13_06_05 UTC) (2015_12_03 14_18_17 UTC).png
Acacia Tree 4 (2014_10_15 02_10_34 UTC) (2015_12_03 14_18_17 UTC).jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}