$re = '/#(\w+)/m';
$str = '#user$,#you #fun #go #userfun024 #assassinscreed2020valhala';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);