package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#(\w+)`)
var str = `#user$,#you #fun #go #userfun024 #assassinscreed2020valhala`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}