// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(#Macro(.|[\r\n])+?#EndMacro)").unwrap();
let string = " #Macro
#object
value=1
value=2
#EndMacroEnt
#object
value=5
value=6
#EndMacroEnt
#EndMacro";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}