package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(#Macro(.|[\r\n])+?#EndMacro)`)
var str = ` #Macro
#object
value=1
value=2
#EndMacroEnt
#object
value=5
value=6
#EndMacroEnt
#EndMacro`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}