$re = '/^\s*while\s*\(\s*(\w+)\s*\)\s*\{\s*$/';
$str = ' while ( condition ) {';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);