package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*while\s*\(\s*(\w+)\s*\)\s*\{\s*$`)
var str = ` while ( condition ) {`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}